INC0064281 - APEX Newbury Exchange (THNU) - Loss of service

Incident Report for amatisnetworks

Monitoring

Services are fully restored and operating normally since yesterday morning.

Our teams will continue to monitor the platform closely for an extended period to ensure everything remains stable.

We appreciate your patience and apologise for the inconvenience.
Posted Mar 04, 2026 - 10:49 GMT

Update

Services appear to have recovered, however we still have engineers on site investigating the root cause.
Posted Mar 03, 2026 - 12:00 GMT

Investigating

We are currently investigating a loss of service at the APEX Newbury exchange, which is affecting ethernet and xDSL services.
Posted Mar 03, 2026 - 09:50 GMT
This incident affects: Connectivity (Ethernet Services (Fibre, EFM, GEA), xDSL Services (ADSL/FTTC)) and Core (Core Network Devices and Routing).