All services have remained stable since the PE router was replaced and this incident is being closed down accordingly.
We understand the inconvenience this fault may have caused and sincerely apologise for the disruption to services. We also want to express our gratitude to our customers for their patience and understanding while we worked to resolve the issue.
Posted Apr 22, 2025 - 16:28 BST
Monitoring
We have successfully replaced the device and and seeing primary services restore. We are continuing to patch the remaining fibres to secondary services.
Posted Apr 11, 2025 - 08:41 BST
Update
Engineers are currently on site to replace the failed device
Posted Apr 11, 2025 - 07:25 BST
Identified
Following planned works one of our core routers in Slough LD5 has failed. We have engaged the vendor and RMA has been raised. Engineers are en route to site to replace and re-patch customer services
Posted Apr 11, 2025 - 06:01 BST
This incident affected: Connectivity (Ethernet Services (Fibre, EFM, GEA)), Core (Core Network Devices and Routing, Private Internet Peering), and Cloud Services (Cloud Connect Backup Storage Service).