Reading Data Centre (RDC) UPS Alarms

Incident Report for amatisnetworks

Resolved

This incident has been resolved
Posted Mar 16, 2026 - 16:15 GMT

Investigating

We are currently seeing alarms on the UPS system in our Reading Data Centre (RDC). Our maintenance vendor has been engaged and is attending site this morning to investigate.

There is currently no impact to services.

We will provide a further update once the vendor has completed their initial assessment.
Posted Mar 16, 2026 - 08:13 GMT
This incident affected: Infrastructure (Power).